Easy Math

题目

Easy Math

Given nn integers a1,a2,…,ana1,a2,…,an, check if the sum of their square root a1−−√+a2−−√+⋯+an−−√a1+a2+⋯+an is a integer.

Input

The input consists of multiple tests. For each test:

The first line contains 11 integer nn (1≤n≤1051≤n≤105). The second line contains nn integers a1,a2,…,ana1,a2,…,an (0≤ai≤1090≤ai≤109).

Output

For each test, write "Yes" if the sum is a integer, or "No" otherwise.

Sample Input

    2
    1 4
    2
    2 3

Sample Output

    Yes
    No

题意:就是给你n个整数,求这n个数的平方根是否为一个整数。算是一个水题吧。

AC代码:

#include<stdio.h>
#include<math.h>
int a[150005];
int main()
{
    int n;
    while(scanf("%d",&n)>0)
    {
        int flag = 1;
        for(int i = 0; i < n ; i ++)
        {
            scanf("%d",&a[i]);
            int p=(int)sqrt( 1.0 * a[i] + 0.5) + 1;
            while(flag)
            {
                if((int) p * p == a[i])
                {
                    break;
                }
                if((int) p * p < a[i])
                {
                     flag = 0;
                }
                p--;
            }

        }
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值