A - Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
题目大意:给出包含N(10 < N < 100 000)个数的序列,其中每个数的大小不超过10000,给出一个正整数S(S < 100 000 000),写一个程序找出最短连续序列使得它们的和大于等于S
思路:设置一个变量index记录当前测试序列的开始位置 ( index初始为0,表示从序列最开始位置进行寻找 , 序列数组保存从0位置开始),使用for循环遍历整个序列数组,sum记录当前序列的和,如果发现sum>=S,说明以 index 开始、j 结尾的序列满足要求,于是更新minlen的值,minlen=min(minlen,j-index+1),注意虽然此时sum>=S,但是很有可能有这样一种情况发生:即使没有从 index 开始的前几项,剩下的序列依然满足题目要求,故此时应将 sum-=num[index] ; sum-=num[j] ; index++ ; j--;(即将原来index位置的数字删除,从index+1处重新统计,这里还需要将j退回前一个位置重新统计)。








 
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
const int maxn=100005;
int main(){
	int num[100005];
	int n,s;
	int cas;
	cin>>cas;
	for(int i=0;i<cas;i++){
		cin>>n>>s;
		for(int j=0;j<n;j++){
			cin>>num[j];
		}
		//读入数字序列
		int sum=0,minlen=maxn;
		int len;
		int index=0;//记录符合要求序列的初始位置 
		for(int j=0;j<n;j++){
			sum+=num[j];
			if(sum>=s){
				len=j-index+1;//末位置减初位置即序列长度
				minlen=min(minlen,len);
				sum-=num[index];//去掉当前找出序列的头部继续向后查找最小长度的序列
				sum-=num[j];//此时要退回到j位置继续进行,因为有可能即使不包括序列第一位序列也会满足要求 
				index++;
				j--; 
			}
		}
		if(minlen==maxn)cout<<0<<endl; 
		else cout<<minlen<<endl; 
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值