1102. Invert a Binary Tree (25)
The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.
Now it's your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:8 1 - - - 0 - 2 7 - - - - 5 - 4 6Sample Output:
3 7 2 6 4 0 5 1 6 5 7 4 3 2 0 1
#include <iostream>
#include<stdio.h>
#include<string>
#include<queue>
#include<algorithm>
#include<string.h>
#include<vector>
#include<map>
#include<math.h>
using namespace std;
struct
{
int lc,rc;
int now;
}node[15];
int mark[15]={0};
void inorder(int xx)
{
static int flag=0;
if(node[xx].lc!=-1) inorder(node[xx].lc);
if(flag==1) cout<<' ';
flag=1;
cout<<xx;
if(node[xx].rc!=-1) inorder(node[xx].rc);
}
void levelorder(int x)
{
queue<int> Q;
Q.push(x);
int flag=0;
while(!Q.empty())
{
int tmp=Q.front();
Q.pop();
if(flag==1) cout<<' ';
flag=1;
cout<<tmp;
if(node[tmp].lc!=-1) Q.push(node[tmp].lc);
if(node[tmp].rc!=-1) Q.push(node[tmp].rc);
}
cout<<endl;
}
int main()
{
int n;
cin>>n;
char a[5],b[5];
for(int i=0;i<n;i++)
{
cin>>a>>b;
if(a[0]=='-') node[i].lc=-1;
else
{
node[i].lc=atoi(a);
mark[atoi(a)]++;
}
if(b[0]=='-') node[i].rc=-1;
else
{
mark[atoi(b)]++;
node[i].rc=atoi(b);
}
swap(node[i].lc,node[i].rc);
node[i].now=i;
}
int start;
for(int i=0;i<n;i++)
if(mark[i]==0)
{
start=i;break;
}
levelorder(start);
inorder(start);
return 0;
}