基于子网的vlan划分配置要点及实例

说明: 1.IP划分vlan只能在hybrid端口上划分

            2.IP划分vlan仅对untagged报文生效
            3.接口默认没有开启IP划分vlan功能
          
配置要点:
第一步:建立vlan
第二步:(vlan模式)设置IP子网vlan地址                        
ip-subnet-vlan ip X.X.X.X 掩码位数
第三步:进入指定接口视图设置接口为hybrid类型                    port link-type hybrid
port link-type hybrid
第四步:设置接口允许通过指定的子网vlan报文
第五步:开启接口的ip子网划分vlan功能

ip-subnet-vlan enable


实验环境:H3C ENSP


交换机1配置:

[Huawei]display current-configuration 
#
sysname Huawei
#
vlan batch 100 200
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
drop-profile default
#
vlan 100
 ip-subnet-vlan 1 ip 192.168.1.0 255.255.255.0
vlan 200
 ip-subnet-vlan 1 ip 192.168.2.0 255.255.255.0
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface Ethernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/2
 port hybrid untagged vlan 2 to 4094
 ip-subnet-vlan enable
#
interface Ethernet0/0/3
 port hybrid untagged vlan 2 to 4094
 ip-subnet-vlan enable
#
interface Ethernet0/0/4
#
interface Ethernet0/0/5
#
interface Ethernet0/0/6
#
interface Ethernet0/0/7
#
interface Ethernet0/0/8
#
interface Ethernet0/0/9
#
interface Ethernet0/0/10
#
interface Ethernet0/0/11
#
interface Ethernet0/0/12
#
interface Ethernet0/0/13
#
interface Ethernet0/0/14
#
interface Ethernet0/0/15
#
interface Ethernet0/0/16
#
interface Ethernet0/0/17
#
interface Ethernet0/0/18
#
interface Ethernet0/0/19
#
interface Ethernet0/0/20
#
interface Ethernet0/0/21
#
interface Ethernet0/0/22
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
#
return

交换机2配置:

[Huawei]display current-configuration 
#
sysname Huawei
#
vlan batch 100 200
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
drop-profile default
#
vlan 100
 ip-subnet-vlan 1 ip 192.168.1.0 255.255.255.0
vlan 200
 ip-subnet-vlan 1 ip 192.168.2.0 255.255.255.0
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface Ethernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/2
 port hybrid untagged vlan 2 to 4094
 ip-subnet-vlan enable
#
interface Ethernet0/0/3
 port hybrid untagged vlan 2 to 4094
 ip-subnet-vlan enable
#
interface Ethernet0/0/4
#
interface Ethernet0/0/5
#
interface Ethernet0/0/6
#
interface Ethernet0/0/7
#
interface Ethernet0/0/8
#
interface Ethernet0/0/9
#
interface Ethernet0/0/10
#
interface Ethernet0/0/11
#
interface Ethernet0/0/12
#
interface Ethernet0/0/13
#
interface Ethernet0/0/14
#
interface Ethernet0/0/15
#
interface Ethernet0/0/16
#
interface Ethernet0/0/17
#
interface Ethernet0/0/18
#
interface Ethernet0/0/19
#
interface Ethernet0/0/20
#
interface Ethernet0/0/21
#
interface Ethernet0/0/22
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
#
return
[Huawei] 

PC4测试图:



PC3测试图:


  • 7
    点赞
  • 1
    评论
  • 17
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

打赏
文章很值,打赏犒劳作者一下
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页

打赏

自由不死

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者