hdoj5363Key Set


Problem Description
soda has a set S with n integers {1,2,,n} . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case:

The first line contains an integer n (1n109) , the number of integers in the set.
 

Output
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
  
  
4 1 2 3 4
 

Sample Output
  
  
0 1 3 7
 

Author
zimpha@zju
 题意:给你一个具有n个元素的集合s{1,2,3,4,,,,n},问该集合的非空子集中和为偶数的非空子集的个数。经过推导,sum=2^(n-1)-1;
此题需要用到快速幂(用于求2^(n-1));
代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long
using namespace std;  
const int mod = 1000000007;
LL quickpow(LL n,LL m)
{
	int ans=1;
	while(m)
	{
		if(m&1)
		{
			ans=n*ans%mod;
		}
		n=n*n%mod;
		m>>=1;
	
	}
	return ans;
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		LL q;
		scanf("%lld",&q);
		LL sum=quickpow(2,q-1)-1;
		printf("%lld\n",sum);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值