居然。。。。B - Number of Containers

For two integers m and k, k is said to be a container of m if k is divisible by m. Given 2 positive integers n and m (m < n), the function f(n, m) is defined to be the number of containers of m which are also no greater than n. For example, f(5, 1)=4, f(8, 2)=3, f(7, 3)=1, f(5, 4)=0…
Let us define another function F(n) by the following equation:
在这里插入图片描述
Now given a positive integer n, you are supposed to calculate the value of F( n).

Input
There are multiple test cases. The first line of input contains an integer T(T<=200) indicating the number of test cases. Then T test cases follow.
Each test case contains a positive integer n (0 < n <= 2000000000) in a single line.

Output
For each test case, output the result F(n) in a single line.

Sample Input
2
1
4

Sample Output
0
4
题意:就是如图所示,求 n/i-1;(0<i<n)的和,,,,由于数据高达20Y,所以,暴力就会T!!!

画图,画出函数图像:y = n/x,以 y = x对称
可以用 横坐标表示i 从该点画一条垂直的线 这条线上的所有整数点的个数就是 n/i
那么n/1+n/2+n/3+……n/(n-2)+n/(n-1)+n/n 可以表示为i*(n/i)=n这条线
答案就是这条线与坐标轴围成的面积内的整数点的个数
画一条x=y的线与xy=n相交 可以知道 面积关于x=y对称
我们求n/1+n/2+n/3+…… 只求到k=sqrt(n)处(1个梯形) 之后乘以2 (得到2个梯形的面积 其中有一个正方形的区域是重复的) 减去重复的区域k
k个 即可

这个方法也可以用来快速求(n/1+n/2+n/3+…+n/n)。

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <ctime>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <bitset>
using namespace std;
#define ll long long
#define MAXN 50005

int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        ll n, sum=0;
        cin >> n;
        int c = sqrt(n);
        for(int i=1; i<=c; ++i)
            sum+=n/i;
        sum*=2;
        sum = sum-c*c-n;
        cout << sum << '\n';
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值