【线段树】A Simple Problem with Integers(区间查询和延迟标记)

A Simple Problem with Integers
Time Limit:5000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

这题其实算是一个模板题,就是将一段序列加一个数,然后查一段序列的和。

要用到区间查询和延迟标记的知识。延迟标记就是在查询时顺便将节点的标记值传给下面的节点,并且删掉标记。修改和查询都要用到。

不懂得推荐看这个博客上的讲解:http://dongxicheng.org/category/structure/page/2/

AC代码如下:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
const int N=100005;
struct node
{
    __int64 l,r,mid,sum,flag;
}t[N<<2];
void build(__int64 l,__int64 r,__int64 k)
{
    t[k].l=l;
    t[k].r=r;
    t[k].flag=0;
    t[k].mid=(l+r)>>1;
    t[k].sum=0;
    if(l==r)
    return ;
    build(l,t[k].mid,2*k);
    build(t[k].mid+1,r,2*k+1);
}
void add(__int64 l,__int64 r,__int64 k,__int64 n)
{
    if(t[k].l==l&&t[k].r==r)
    {
        t[k].sum+=n*(r-l+1);
        t[k].flag+=n;
        return ;
    }
    if(t[k].flag!=0)
    {
        t[2*k].sum+=t[k].flag*(t[2*k].r-t[2*k].l+1);
        t[2*k].flag+=t[k].flag;
        t[2*k+1].sum+=t[k].flag*(t[2*k+1].r-t[2*k+1].l+1);
        t[2*k+1].flag+=t[k].flag;
        t[k].flag=0;
    }
    if(r<=t[k].mid)
    add(l,r,2*k,n);
    else if(l>=t[k].mid+1)
    add(l,r,2*k+1,n);
    else
    {
        add(l,t[k].mid,2*k,n);
        add(t[k].mid+1,r,2*k+1,n);
    }
    t[k].sum=t[2*k].sum+t[2*k+1].sum;
}
__int64 search(__int64 l,__int64 r,__int64 k)
{
    if(t[k].l==l&&t[k].r==r)
    return t[k].sum;
    if(t[k].flag!=0)
    {
        t[2*k].sum+=t[k].flag*(t[2*k].r-t[2*k].l+1);
        t[2*k].flag+=t[k].flag;
        t[2*k+1].sum+=t[k].flag*(t[2*k+1].r-t[2*k+1].l+1);
        t[2*k+1].flag+=t[k].flag;
        t[k].flag=0;
    }
    __int64 ans=0;
    if(r<=t[k].mid)
    ans=search(l,r,2*k);
    else if(l>=t[k].mid+1)
    ans=search(l,r,2*k+1);
    else
    {
        ans+=search(l,t[k].mid,2*k);
        ans+=search(t[k].mid+1,r,2*k+1);
    }
    return ans;
}
int main()
{
    __int64 a[N];
    __int64 n,m,i,j,x,y,z;
    char q;
    scanf("%I64d%I64d",&n,&m);
    build(1,n,1);
    for(i=1;i<=n;i++)
    {
        scanf("%I64d",&a[i]);
        add(i,i,1,a[i]);
    }
    while(m--)
    {
        getchar();
        scanf("%c",&q);
        if(q=='C')
        {
            scanf("%I64d%I64d%I64d",&x,&y,&z);
            add(x,y,1,z);
        }
        else
        {
            scanf("%I64d%I64d",&x,&y);
            printf("%I64d\n",search(x,y,1));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值