杭电5606 tree

tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 715    Accepted Submission(s): 340


Problem Description
There is a tree(the tree is a connected graph which contains  n  points and  n1  edges),the points are labeled from 1 to  n ,which edge has a weight from 0 to 1,for every point  i[1,n] ,you should find the number of the points which are closest to it,the clostest points can contain  i  itself.
 

Input
the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer  n ,means the number of the points,next n-1 lines,each line contains three numbers  u,v,w ,which shows an edge and its weight.

T50,n105,u,v[1,n],w[0,1]
 

Output
for each test case,you need to print the answer to each point.

in consideration of the large output,imagine  ansi  is the answer to point  i ,you only need to output, ans1 xor ans2 xor ans3.. ansn .
 

Sample Input
  
  
1 3 1 2 0 2 3 1
 

Sample Output
  
  
1 in the sample. $ans_1=2$ $ans_2=2$ $ans_3=1$ $2~xor~2~xor~1=1$,so you need to output 1.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5609  5608  5607  5605  5604 
 
给的意思是,给定点A和点B,如果这两个点的距离为0,那么把这两个点定为一棵树上,要求解出每一个点所在数上点的个数进行异或,求得结果,使用并查集:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int per[110000],i,j,k,l,m,n,a[110000],help[110000];//help数组就是当前点所在 
struct node//树上的所有点的个数 
{
	int start;
	int end;
	int cost;
}t[110000];
int find(int x)
{
	if(per[x]==x)
	return x;
	return per[x]=find(per[x]);
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fx]=fy;//如果这两个点不在一棵树上 
		help[fy]+=help[fx];//把他们定在一棵树上, 
	}
	
}
int main()
{
	int p;
	scanf("%d",&p);
	while(p--)
	{
		scanf("%d",&n);
		for(i=0;i<=n;i++)
		{
			per[i]=i;
			help[i]=1;
		}
		for(i=1;i<n;i++)
		{
			scanf("%d%d%d",&t[i].start,&t[i].end,&t[i].cost);
			if(t[i].cost==0)
			join(t[i].start,t[i].end);
		}
		int ans=help[find(1)];
		for(i=2;i<=n;i++)
		ans^=help[find(i)];
		printf("%d\n",ans);
	}
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值