HDUoj 5606 tree ( 并查集

tree

Description

There is a tree(the tree is a connected graph which contains nn points and n−1n−1 edges),the points are labeled from 1 to nn,which edge has a weight from 0 to 1,for every point i∈[1,n]i∈[1,n],you should find the number of the points which are closest to it,the clostest points can contain ii itself.

Input

the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer nn,means the number of the points,next n-1 lines,each line contains three numbers u,v,wu,v,w,which shows an edge and its weight.

T≤50,n≤105,u,v∈[1,n],w∈[0,1]

Output

for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i,you only need to output,ans1 xor ans2 xor ans3.. ansn.

Sample Input

1
3
1 2 0
2 3 1

Sample Output

1

Hint

in the sample.

$ans_1=2$

$ans_2=2$

$ans_3=1$

$2~xor~2~xor~1=1$,so you need to output 1.

题意

给您一棵树 权值为1或者0 求 一个点相邻点的个数(权值为0

题解:

并查集求联通快 每个联通快的大小即每个点相邻的点数

AC代码

#include <bits/stdc++.h>
using namespace std;
const int N = 100010;
int par[N],num[N];
void init(int n)
{
    for(int i = 1;i <= n; i++) {
        par[i] = i;;
    }
}
int find(int x)
{
    if(x == par[x]) return x;
    return par[x] = find(par[x]);
}
void unite(int x, int y)
{
    x = find(x);
    y = find(y);
    if(x != y) 
    par[x] = y;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--) {
        memset(num,0,sizeof(num));
        int n;
        scanf("%d",&n);
        init(n);
        int u, v, w;
        for(int i = 0;i < n-1; i++) {
            scanf("%d%d%d",&u,&v,&w);
            if(w == 0) unite(u,v);
        }
        for(int i = 1;i <= n; i++) {
            num[find(i)]++;
        }
        int ans = num[find(1)];
        for(int i = 2;i <= n; i++) {
            ans ^= num[find(i)];
        }
        printf("%d\n",ans);
    }
return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值