HDU 5606 tree(并查集的应用)

109 篇文章 0 订阅
23 篇文章 0 订阅

Problem Description
There is a tree(the tree is a connected graph which contains n points and n−1 edges),the points are labeled from 1 to n,which edge has a weight from 0 to 1,for every point i∈[1,n],you should find the number of the points which are closest to it,the clostest points can contain i itself.

Input
the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer n,means the number of the points,next n-1 lines,each line contains three numbers u,v,w,which shows an edge and its weight.

T≤50,n≤105,u,v∈[1,n],w∈[0,1]

Output
for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i,you only need to output,ans1 xor ans2 xor ans3.. ansn.

Sample Input
1
3
1 2 0
2 3 1

Sample Output
1

in the sample.

ans1=2

ans2=2

ans3=1

2 xor 2 xor 1=1 ,so you need to output 1.


城会玩题目,感觉挺有意思的,,,,水一发题解吧。。。

本题的题意:让你找出离每个点最近的点的个数,然后把这些个数异或。
找点的个数这块用到了并查集的有关知识。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int pre[100005];

int fin(int x)
{
    if(pre[x]==x)
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    if(t1!=t2)
    {
        pre[t1]=t2;
    }
}

int cnt[100005];
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int a,b,c;
        for(int i=1;i<=n;i++)
        {
             pre[i]=i;
        }
        for(int i=1;i<=n-1;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(c==0)//因为每个点的最近距离肯定为0,为1的话就不需要考虑了
            join(a,b);
            cnt[i]=0;
        }
        cnt[n]=0;
        for(int i=1;i<=n;i++)
        {
            cnt[fin(i)]++;//找到祖先后,加一
        }
        int re=0;
        for(int i=1;i<=n;i++)
        {
            re=re^cnt[fin(i)];
        }
        printf("%d\n",re);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值