Parity check

Think:
PS : 题目出处 “浪潮杯”山东省第八届ACM大学生程序设计竞赛
注意 最后输出的结果时 f(n) % 2 所以 结果 只可能时 0 或 1

Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:

f(n)=这里写图片描述

She is required to calculate f(n) mod 2 for each given n. Can you help her?
Input

Multiple test cases. Each test case is an integer n(0≤n≤) in a single line.
Output

For each test case, output the answer of f(n)mod2.
Example Input

2

Example Output

1

***Hint
Author***
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

#include<bits/stdc++.h>
using namespace std;
int main()
 {
  char str[1050];
  int i;
  while(~scanf("%s", str))
    {
      int d = strlen(str);
      int k = 0;
      for (i = 0;i <= d - 1;i ++)
        {
           k = k + str[i] - '0';
    }
           if (k % 3 == 0)
             printf("0\n");
             else
             printf("1\n");
    }
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值