1086 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N(≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路:此题可以转换为知道前序和中序,让你求后序题目,用pre_order保存顺次出现的节点,为其树的前序遍历,用in_order保存按出栈顺序的节点,为其树的中序遍历,最后建树,递归后序遍历,直接A!!

#include<iostream>
#include<vector>
#include<stack>
using namespace std;
int n;
vector<int> in_order;
vector<int> pre_order;
struct node{

    int data;
    node *lchild;
    node *rchild;
};
node * creat(int pre_start, int pre_end, int in_start, int in_end){
    if(pre_start > pre_end || in_start > in_end){
        return NULL;
    }
    node * root = new node();
    root -> data = pre_order[pre_start];
    int flag;
    for(int i = 0; i < n; i++){
        if(pre_order[pre_start] == in_order[i]){
            flag = i;
        }
    }
    root -> lchild = creat(pre_start + 1, flag - in_start + pre_start, in_start, flag - 1);
    root -> rchild = creat(pre_end - in_end + flag + 1, pre_end, flag + 1, in_end);

    return root;

}
int m = 0;
void post_order(node * t){

    if(t == NULL){
        return;
    }
    post_order(t -> lchild);
    post_order(t -> rchild);
    printf("%s%d", m == 0 ? "" : " ", t -> data);
    m++;
}
int main(){

    cin >> n;
    stack<int> sta; 
    for(int i = 0; i < 2 * n; i++){
        string s;
        int temp;
        cin >> s;
        if(s == "Push"){
            scanf("%d", &temp);
            sta.push(temp);
            pre_order.push_back(temp);
        }else
        {
            in_order.push_back(sta.top());
            sta.pop();
        }
        

    }
    node * tree = creat(0, n -1, 0, n -1);
    post_order(tree);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值