1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., Nand pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of Nnumbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include<iostream>

#include<vector>
#include<stack>
using namespace std;

int main(){

    int m, n, k;
    cin >> m >> n >> k;
    
    for(int i = 0; i < k; i++){
        vector<int> vec(n + 1);
        for(int j = 1; j <= n; j++){
            scanf("%d", &vec[j]);

        }
        stack<int> s;
        bool visit[1005] = {false};
        bool flag = true;
        int pre_max = 0;
        for(int j = 1; j <= n; j++){
            if((vec[j] - pre_max) > (m - int(s.size()))){
               
                flag = false;
                printf("NO\n");
                break;
            }else
            {
                
                if(vec[j] > pre_max){
                    int temp = pre_max + 1;
                    while (temp < vec[j])
                    {
                        s.push(temp);
                        temp++;
                    }
                    visit[vec[j]] = true;
                }else
                {
                    if(s.top() == vec[j]){
                        visit[vec[j]] = true;
                        s.pop();
                    }else
                    {
                        flag = false;
                        printf("NO\n");
                        break;
                    }
                    


                }

                pre_max = max(vec[j], pre_max);
                    
            }
            

        }
        if(flag){

            printf("YES\n");
        }
        

    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值