POJ-2151-Check the difficulty of problems

Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6653 Accepted: 2889

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972


给出问题数M, 小组个数T和希望N, 下面T行,每行M个数据,代表i小组解出第j题的概率
求每个小组至少解出一题且有小组解出题数不少于希望题数

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
int m, t, n;
double Map[1001][35];
double dp[1001][31][31];// 第i个小组在前j题中解出k题的概率
double dp2[1001][31];//第i个小组中解出不多于j题的概率
int main()
{
    while(~scanf("%d%d%d", &m,&t,&n)&&(n||m||t))
    {
        for(int i = 1; i<=t; ++i)
        {
            for(int j = 1; j<=m; ++j)
                scanf("%lf", &Map[i][j]);
            dp[i][0][1] = 0.0;
            dp[i][0][0] = 1.0;
            for(int j = 1; j<=m; ++j)
                dp[i][j][0] = dp[i][j-1][0]*(1.0-Map[i][j]);   // 第i个小组前j个题解出0题的概率  
            for(int j = 1; j<=m; ++j)
                for(int k = 1; k<=m; ++k)
                    dp[i][j][k] = dp[i][j-1][k]*(1.0-Map[i][j])+dp[i][j-1][k-1]*Map[i][j];
            dp2[i][0]=  dp[i][m][0];
            for(int j = 1; j<=m; ++j)
                dp2[i][j] = dp2[i][j-1]+dp[i][m][j];
        }
        double p2 = 1.0; //所有小组解出1到n-1个题
        double p1 = 1.0;// 所有小组解出0题
        for(int i = 1; i<=t; ++i)
        {
            p2*=(dp2[i][n-1]-dp2[i][0]);
            p1*=(1.0-dp2[i][0]);
        }
        printf("%.3f\n", p1-p2);

    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值