Equations HDU - 1496(哈希或三层for循环)求满足公式有多少种情况

题意:求x在(-100<=x<=100)区间上,已知a,b,c,d,满足a*x1^2+b*x2^2+c*x3^2+d*x4^2=0 的情况有多少种

思路:很明显四层for循环肯定超时,可用三层for循环来判断,或是,两两组合,求多少种情况。分正负故最后

要乘上2^4;

题目

Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0 
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0. 

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}. 

Determine how many solutions satisfy the given equation. 

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks. 
End of file.

Output

For each test case, output a single line containing the number of the solutions. 

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0

AC代码

哈希:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f1[1000005],f2[1000005];//f1保存得数是正的  f2保存得数是负的
int a,b,c,d;
int main()
{
    while(~scanf("%d%d%d%d",&a,&b,&c,&d))
    {
        if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0)) //abcd全部大于0或者小于0,肯定无解。要加上这个,不然超时
        {
            printf("0\n");
            continue;
        }
        memset(f1,0,sizeof(f1));
        memset(f2,0,sizeof(f2));
        for(int i=1; i<=100; i++)
            for(int j=1; j<=100; j++)
            {
                int ans=a*i*i+b*j*j;
                if(ans>=0) f1[ans]++;
                else f2[-ans]++;
            }
        int sum=0;
        for(int i=1; i<=100; i++)
            for(int j=1; j<=100; j++)
            {
                int ans=c*i*i+d*j*j;
                if(ans>0) sum+=f2[ans];
                else sum+=f1[-ans];
            }
        printf("%d\n",16*sum);//每个解有正有负,结果有2^4种
    }
    return 0;
}

三层for循环:

#include<iostream>
#include<cstdio>
#include<cmath>/*暴力*/
#include<cstring>
using namespace std;
int main()
{
    int a,b,c,d;
    while(~scanf("%d%d%d%d",&a,&b,&c,&d))
    {
        if(a>0&&b>0&&c>0&&d>0||a<0&&b<0&&c<0&&d<0)
        {
            printf("0\n");
            continue;
        }
        int sum=0;
        for(int i=1; i<=100; i++)//因为正负号不同不影响平方的效果,所以只枚举正数
            for(int j=1; j<=100; j++)
                for(int l=1; l<=100; l++)
                {
                    int f=a*i*i+b*j*j+c*l*l;
                    if(f%d==0)
                    {
                        int h=sqrt(abs((0-f)/d));
                        if(h<=100&&h>0&&h*h==abs((0-f)/d)&&f+d*h*h==0)
                            sum++;
                    }
                }
        printf("%d\n",sum*16);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值