1099 - 萌萌哒的第四题
Time Limit:2s Memory Limit:128MByte
Submissions:427Solved:260
DESCRIPTION
给一个数x,定义一个函数f(x)的结果是x的各位数字的平方和,若经过无数次递归操作之后若结果为1,也就是f(f(f(...f(x)...)))=1,那么这个数被认为是一个特别的数。给出一个数x请问这个数是否特别。
INPUT
包含多组测试数据(<=20),每组数据一行一个整数x(1<=x<=1000000000)
OUTPUT
每组数据输出一行YES表示是一个特别的数,否则输出NO
SAMPLE INPUT
19
2
14
SAMPLE OUTPUT
YES
NO
NO
#include<iostream>
#include<cstdio>
using namespace std;
int n=0;
int f(int x)
{
n++;
int a=0;
while(x)
{
a=a+(x%10)*(x%10);
x=x/10;
}
if(a==1)
return 1;
else if(n>100)
return 0;
else
return f(a);
}
int main()
{
int x;
while(scanf("%d",&x)!=EOF)
{
n=0;
if(f(x)==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}