POJ1142 Smith Numbers(分治法)

Smith Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14074 Accepted: 4804
Description


While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 
4937775= 3*5*5*65837


The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers. 
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition. 
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!
Input


The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.
Output


For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.
Sample Input


4937774
0
Sample Output


4937775

题意就是给你一个数n,看大于n的一个数,这个数的各个位数相加的和等于它质因子各个位数相加的和,但是素数满足这个要求所以素数就可以不用看了,虽然要大于n的一个数,但这个数要最小。这个题暴力就可以做,我看了分治感觉很有道理就发个博客记录一下

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int sushu(int x)
{
    int k=sqrt(x+0.5);
    for(int i=2; i<=k; i++)
        if(x%i==0)
            return 0;
    return 1;
}
int sum(int x)
{
    int ans=0;
    while(x)
    {
        ans+=x%10;
        x/=10;
    }
    return ans;
}
int cut(int x)//分治,也是一个递归,但是有一点利用了分治的思想
{
    if(sushu(x))
        return sum(x);
    for(int i=(int)sqrt(x+0.5); i>1; i--)//素数直接就从开根号开始找
        if(x%i==0)//符合条件,是质因子
            return cut(i)+cut(x/i) ;//把一个数拆成两个数,分开去找
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        while(n++)
        {
            if(!sushu(n)&&sum(n)==cut(n))
                 break;
        }
        printf("%d\n",n);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值