【hdu】Phone List (字典树)

Phone List

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 3
Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

 

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts withn, the number of phone numbers, on a separate line, 1 ≤n ≤ 10000. Then followsn lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

 

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

 

Sample Input
    
    
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
    
    
NO YES
 

Source
PKU
 这道题我是用STL做的,发现了一个奇怪的东西啊,把v.clear()放在循环里面竟然超时,下次要注意了,宁可浪费一点内存,也不写v.clear()了!!!

直接每个循环都定义一个vector<string> v;
puts比printf快,且不用多写\n
#include<cstdio>
#include<vector>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int T,n;
    scanf("%d",&T);
    char str[100];
    while(T--)
    {
          scanf("%d",&n);        
          //v.clear();
           vector<string> v;
          int k=n;
          while(n--)
          {
                    scanf("%s",str);
                    v.push_back(string(str));
          }
          sort(v.begin(),v.end());
          int flag=0;
          for(int i=0;i<k-1;i++)
          {
             if(v[i+1].find(v[i])!=-1) {flag=1;printf("NO\n");break;}
             else continue;
          }
          if(!flag) printf("YES\n");
    }
    return 0;
}
             
附上转载的字典树代码,只把电话号码的最后一位num置为1,比较好。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 120100
int count;

struct Dictree //字典树数据结构
{
	int num;
	Dictree *tire[10];
}*head;
Dictree Head[MAXN];

bool insert(char str[])
{
	int len, temp;
	len = strlen(str);
	head = &Head[0]; //头结点是字典树入口,没有数据
	for(int i = 0; i < len; ++i)
	{
		temp = str[i] - 48;
		if(head->tire[temp] == NULL)
			head->tire[temp] = &Head[++count]; //字母无出现,则赋予空间
		head = head->tire[temp];
		if(head->num) //该电话是否含有其他电话
			return false;
	}
	head->num = 1;
	for(int i = 0; i < 10; ++i) //该电话是否是其他电话的前缀
		if(head->tire[i] != NULL)
			return false;
	return true;
}

int main()
{
	//freopen("Input.txt", "r", stdin);
	int ncase;
	int num;
	bool flag;
	char str[12];
	scanf("%d", &ncase);
	while(ncase--)
	{
		flag = true; //标记是否有不符合条件的电话
		count = 0;
		memset(Head, 0, sizeof(Head));
		scanf("%d", &num);
		for(int i = 1; i <= num; ++i)
		{
			scanf("%s", str);
			if(flag == false) //有则不用处理(空插,太巧妙了~~~~)
				continue;
			if(insert(str) == false)
				flag = false;
		}
		if(flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}     
转Ted的静态字典树:
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    int next[10];
    int id;
}head[100005];
bool flag;
int cnt;
char s[10005][15];
void build(char *t,int idx,int id)
{
    int len=strlen(t),k;
    for(int i=0;i<len;++i)
    {
        k=t[i]-'0';
        if(head[idx].next[k]==0)
           head[idx].next[k]=(cnt++);
        if((head[idx].id)&&(head[idx].id!=id))
            flag=false;
        idx=head[idx].next[k];
    }
    head[idx].id=id;
}
int main()
{
    int cas,n;
    scanf("%d",&cas);
    for(;cas--;)
    {
        flag=true;
        cnt=1;
        scanf("%d",&n);
        memset(head,0,sizeof(head));
        for(int i=1;i<=n;++i)
        {
            scanf("%s",s[i]);
            build(s[i],0,i);
        }
        if(flag==false)
        {
            puts("NO");
            continue;
        }
        for(int i=1;i<=n;++i)
        {
            build(s[i],0,i);
            if(flag==false) break;
        }
        if(flag) puts("YES");
        else     puts("NO");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值