The Number Off of FFF
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2836 Accepted Submission(s): 942
Problem Description
X soldiers from the famous "
*FFF*
army" is standing in a line, from left to right.
You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
Input
The rst line has a number T (T <= 10) , indicating the number of test cases.
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10 5)
It guaranteed that there is exactly one soldier who has made the mistake.
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10 5)
It guaranteed that there is exactly one soldier who has made the mistake.
Output
For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
Sample Input
2 3 1 2 4 3 1001 1002 1004
Sample Output
Case #1: 3 Case #2: 3
Source
Recommend
zhuyuanchen520
如果后一个都是在前一个的基础上增一,那么就是第一个人报错了(PS:自己在做题的时候,一直认为第一个人一定不会报错,可结果怎么做都是WA,最后看了学长的解题报告,又仔细读了一遍题意,问了问同学,在知道原来自己错这儿了>_<||)
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
#include<stdio.h>
#include<string.h>
int a[100010];
int main()
{
int T, t, num;
scanf("%d", &T);
for(int t=1;t<=T;t++)
{
int n;
scanf("%d", &n);
for(int i=0;i<n;i++)
{
scanf("%d", &a[i]);
}
int f=1;
for(int i=0;i<n-1;i++)
{
if(a[i+1]-a[i]!=1)
{
f=0;
num=i+2;
break;
}
}
if(f==1)
printf("Case #%d: 1\n", t);
else
printf("Case #%d: %d\n", t, num);
}
return 0;
}