poj1543Perfect Cubes

Description

For hundreds of years Fermat's Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.) It is possible, however, to find integers greater than 1 that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.

Input

One integer N (N <= 100).

Output

The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.

Sample Input

24

Sample Output

Cube = 6, Triple = (3,4,5)
Cube = 12, Triple = (6,8,10)
Cube = 18, Triple = (2,12,16)
Cube = 18, Triple = (9,12,15)
Cube = 19, Triple = (3,10,18)
Cube = 20, Triple = (7,14,17)
Cube = 24, Triple = (12,16,20)
 
     
代码:
#include <stdio.h>  
#include <math.h>  
int main()  
{  
    int n,a,b,c,d;  
    __int64 q[101];  
    while(scanf("%d",&n)!=EOF)  
    {  
        for(int  i=1; i<=n; i++)  
        {  
            q[i]=i*i*i;  
        }  
        for(a=6; a<=n; a++)  
            for(b=2; b<a-1; b++)  
            {  
                if(q[a]<q[b]+q[b+1]+q[b+2])  
                    break;  
                for(c=b+1; c<a; c++)  
                {  
                    if(q[a]<q[b]+q[c]+q[c+1])  
                        break;  
                    for(d=c+1; d<a; d++)  
                        if(q[a]==q[b]+q[c]+q[d])  
                            printf("Cube = %d, Triple = (%d,%d,%d)\n",a,b,c,d);  
                }  
            }  
    }  
    return 0;  
}  

思路:从小到大,分层求解
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值