poj 2075 Tangled in Cables

Tangled in Cables

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 6
Problem Description
You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.
 

Input
Only one town will be given in an input.
  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {az,AZ,09} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.
 

Output
The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).
 

Sample Input
  
  
100.0 4 Jones Smiths Howards Wangs 5 Jones Smiths 2.0 Jones Howards 4.2 Jones Wangs 6.7 Howards Wangs 4.0 Smiths Wangs 10.0
 

Sample Output
  
  
Need 10.2 miles of cable
这题是最小树的变形,将各个名字转化为点,最小树求即可!当然还有长度要求!
代码:
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
#define N 1010
char s[10000][30];
double map[N][N],cost[N],m,outcome;
int country,road,v[N];
void prim()
{
	int i,j,next;
	double mincost;
	memset(v,0,sizeof(v));
	for(i=0;i<country;i++)
	{
	 cost[i]=map[0][i];
   
	 }
	 v[0]=1;
	 for(i=1;i<country;i++)//寻找最短的距离 
	  {
	  	mincost=INF;
	  	for(j=0;j<country;j++)
	  	 {
	  	 	if(!v[j]&&mincost>cost[j])
	  	 	{
	  	 		mincost=cost[j];
	  	 		next=j;
			}
		   }
		   outcome+=mincost;
		   v[next]=1;
		   for(j=0;j<country;j++)//更新路径 
		    {
		    	if(!v[j]&&cost[j]>map[next][j])
		    	{
		    		cost[j]=map[next][j];
				}
			}
	  }
}
int main()
{
	int i,j;
	double l;
	char a[30],b[30];
	while(scanf("%lf",&m)!=EOF)
	{
	scanf("%d",&country);
	for(i=0;i< country;i++)
	 scanf("%s",s[i]);
	 scanf("%d",&road);
	 for(i=0;i<country;i++)
	  {
	  	for(j=0;j<country;j++)
	  	 {
	  	 	if(i==j)
	  	 	map[i][j]=0;
	  	 	else
	  	 	map[i][j]=INF;
		   }
	  }
	 for(i=0;i<road;i++)//字符转化为点 
	  {
	  	scanf("%s%s%lf",a,b,&l);
	  	int k,t;
	  	for(j=0;j<country;j++)
	  	{
	  		if(strcmp(s[j],a)==0)
	  		 k=j; 
		}
		  for(j=0;j<country;j++)
		   {
		   	
		   		if(strcmp(s[j],b)==0)
	  		      t=j;
		   }
		    map[t][k]=map[k][t]=l;
	  }
	  prim();
	  if(outcome<=m)
	  printf("Need %.1f miles of cable\n",outcome);
	  else
	  printf("Not enough cable\n");
	return 0;
}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值