Find Q

Problem Description
Byteasar is addicted to the English letter 'q'. Now he comes across a string  S  consisting of lowercase English letters.

He wants to find all the continous substrings of  S , which only contain the letter 'q'. But this string is really really long, so could you please write a program to help him?
 

Input
The first line of the input contains an integer  T(1T10) , denoting the number of test cases.

In each test case, there is a string  S , it is guaranteed that  S  only contains lowercase letters and the length of  S  is no more than  100000 .
 

Output
For each test case, print a line with an integer, denoting the number of continous substrings of  S , which only contain the letter 'q'.
 

Sample Input
  
  
2 qoder quailtyqqq
 

Sample Output
  
  
1 7  

Source
思路:应该是水题,看有几个连着的q,设为K,则sum+=q*(q+1)即可;
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[110000];
int main()
{
    int t,l,i;
    long long sum,k;
    scanf("%d",&t);
    while(t--)
    {
    sum=k=0;
    scanf("%s",str);
    l=strlen(str);
    for(i=0;i<l;i++)
    {
    if(str[i]=='q')
    k++;    
    else
    {
    sum+=k*(k+1)/2;
    k=0; 
    }
    }
    sum+=k*(k+1)/2;
    printf("%lld\n",sum);        
    }        
    return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值