1.3A+Bfor Input-Output Practice (III)(附翻译)


Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35326 AcceptedSubmission(s): 18995

Problem Description

Your task is to Calculate a + b.

Input

Input contains multiple test cases. Eachtest case contains a pair of integers a and b, one pair of integers per line. Atest case containing 0 0 terminates the input and this test case is not to beprocessed.

输入包含多个测试用例。 每个测试用例都包含一对整数a和b,每行一对整数。 包含0 0的测试用例终止输入,并且该测试用例不被处理。


Output

For each pair of input integers a and byou should output the sum of a and b in one line, and with one line of outputfor each line in input.

对于每对输入整数a和b你应该在一行中输出a和b的总和,并在输入中输出每行的一行输出。

Sample Input

1 5
10 20
0 0

Sample Output

6
30

c++
#include<iostream>
using namespace std;
int main(){
	int a,b;
	while(cin>>a>>b){
		if(a==0&&b==0)
			break;//如果输入的是0 0 跳出循环,终止程序
		else
			cout<<a+b<<endl;	
	}	
	return 0;
}

运行截图




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值