poj2258 The Settlers of Catan(简单dfs)

The Settlers of Catan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1435 Accepted: 936

Description

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.  
You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:  

When the game ends, the player who built the longest road gains two extra victory points.  
The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).  
Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes.  
The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.  

Example: The following network contains a road of length 12.  
o      o--o      o

 \    /    \    /

  o--o      o--o

 /    \    /    \

o      o--o      o--o

           \    /

            o--o

Input

The input will contain one or more test cases.  
The first line of each test case contains two integers: the number of nodes n (2<=n<=25) and the number of edges m (1<=m<=25). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.  
Input will be terminated by two values of 0 for n and m.

Output

For each test case, print the length of the longest road on a single line.

Sample Input

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output

2
12

Source

觉得还是没能很好的理解回溯的用法...还是要少刷知乎多刷题(=゜ω゜)ノ

附上AC代码:

#include<iostream>
#include<cstring>

using namespace std;

const int N=100;
const int INF=0x3f3f3f3f;

int n,m,j,k;
int maxn;
int e[N][N];

void dfs(int u,int sum) {
	for(int i = 0; i < n; i++) {
		if(e[u][i]) {
			e[u][i]--;
			e[i][u]--;
			
			dfs(i,sum+1);
			
			e[u][i]++;
			e[i][u]++;
			

		}
	}
	
	if(sum > maxn) {
		maxn = sum;
	}
	
}
void init(){
	memset(e,0,sizeof(e));
	for(int i = 0; i < m; i++) {
			cin>>j>>k;
			e[j][k]++;
			e[k][j]++;
		}
	maxn=-INF;
}
int main() {
	while(cin>>n>>m,n||m) {
		init();
		for(int i = 0;i<n;i++) {
			dfs(i,0);
		}
		cout<<maxn<<endl;
	}
	return 0;
}
poj不能用万能头文件?嘤嘤嘤QAQ

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 1321 排兵布阵问题可以使用 DFS 算法求解。 题目要求在一个 n x n 的棋盘上,放置 k 个棋子,其中每行、每列都最多只能有一个棋子。我们可以使用 DFS 枚举每个棋子的位置,对于每个棋子,尝试将其放置在每一行中未被占用的位置上,直到放置了 k 个棋子。在 DFS 的过程中,需要记录每行和每列是否已经有棋子,以便在尝试放置下一个棋子时进行判断。 以下是基本的 DFS 模板代码: ```python def dfs(row, cnt): global ans if cnt == k: ans += 1 return for i in range(row, n): for j in range(n): if row_used[i] or col_used[j] or board[i][j] == '.': continue row_used[i] = col_used[j] = True dfs(i + 1, cnt + 1) row_used[i] = col_used[j] = False n, k = map(int, input().split()) board = [input() for _ in range(n)] row_used = [False] * n col_used = [False] * n ans = 0 dfs(0, 0) print(ans) ``` 其中,row 代表当前尝试放置棋子的行数,cnt 代表已经放置的棋子数量。row_used 和 col_used 分别表示每行和每列是否已经有棋子,board 则表示棋盘的状态。在尝试放置棋子时,需要排除掉无法放置的位置,即已经有棋子的行和列,以及棋盘上标记为 '.' 的位置。当放置了 k 个棋子时,即可计数一次方案数。注意,在回溯时需要将之前标记为已使用的行和列重新标记为未使用。 需要注意的是,在 Python 中,递归深度的默认限制为 1000,可能无法通过本题。可以通过以下代码来解除限制: ```python import sys sys.setrecursionlimit(100000) ``` 完整代码如下:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值