1009 Product of Polynomials (25分)

1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​ aN​1​​ ​​ N2​​ a​N​2​​ ​​ … NK​​ a​N​K​​ ​​ where K is the number of nonzero terms in the polynomial, N​i​ and a​N​i​​ ​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

本题思路:用vector<pair < int,double>>来存储两行数据,遍历两组数据模拟乘法过程。

AC代码

#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
typedef pair<int,double> PII;

int a,b;
vector<PII> ans1,ans2;
double ans[2020];
int res;

int main()
{
    cin >> a;
    int t;
    double num;
    for(int i=0;i<a;i++)
    {
        cin >> t >> num;
        ans1.push_back({t,num});
    }
    cin >> b;
    for(int i=0;i<b;i++)
    {
        cin >> t >> num;
        ans2.push_back({t,num});
    }
    for(int i=0;i<ans1.size();i++)
    {
        for(int j=0;j<ans2.size();j++)
        {
            int p=ans1[i].first+ans2[j].first;
            if(fabs(ans[p])<1e-6) res++;
            ans[p]+=(double)ans1[i].second*ans2[j].second;
            if(fabs(ans[p])<1e-6)
                res--;
        }
    }
    cout << res;
    for(int i=2020;i>=0;i--)
    {
        if(fabs(ans[i])>1e-6)
            printf(" %d %.1lf",i,ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值