1007 Maximum Subsequence Sum (25分)
Given a sequence of K integers { N1, N2 , …, NK }. A continuous subsequence is defined to be { N
i , Ni+1 , …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
本题思路:DP
用一个数组f来表示最大子区间的和,以f[i]表示为以i为区间右端点的最大值,则有f[i]=max(a[i],f[i-1]+a[i]),左边那项表示最大区间的长度为1,右边表示长度大于一,又因为区间必须以i为右端点,因此等于f[i-1]加上a[i]
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int n;
vector<int> a(100010);
int main()
{
cin >> n;
for(int i=0;i<n;i++)
cin >> a[i];
int res = -1, l, r;
for (int i=0,f=-1,start;i<n;i++)
{
if(f<0)
{
f=0;
start = i; //当f[i-1]<0,则无论a[i]为正为负加上一个小于0的区间和必然只会更小,因此将区间起始位置置为i,并且在此时若最左边为0也不会被除去,保证区间左边位置的最小
}
f+=a[i];
if(res<f) //得到的结果严格之前的最大值才会更新,保证区间右边的0会被去除
{
res=f;
l=a[start],r=a[i];
}
}
if (res<0) res = 0, l = a[0], r = a[n-1];
printf("%d %d %d",res,l,r);
return 0;
}