poj1742 多重背包

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意:有n种硬币,价值不超过m的商品,每个硬币对应一个价值w[i]和数量c[i],求这些硬币恰好能够组合成不超过m的价值的方案数。

思路:楼教主的男人八题之一,算是一个经典的问题,定义一个sum数组。每次填dp[j]时直接由dp[j-w[i]]推出,前提是sum[j-w[i]]<c[i]。 sum每填一行都要清零,sum[j]表示当前物品填充j大小的价值需要至少使用多少价值为w[i]的硬币数量。

#include <iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int n,m;
int w[105],c[105],num[100005];
bool dp[100005];

int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        for(int i=0; i<n; i++)
        {
            cin>>w[i];
        }
        for(int i=0; i<n; i++)
        {
            cin>>c[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        int ans=0;
        for(int i=0; i<n; i++)
        {
            memset(num,0,sizeof(num));
            for(int j=w[i]; j<=m; j++)
            {
                if(!dp[j]&&dp[j-w[i]]&&num[j-w[i]]<c[i])//价值为j的还没凑齐,但是j-w[i]的已经凑齐,并且剩下需要凑齐的数量要小于已有的c[i].
                {
                    dp[j]=1;
                    num[j]=num[j-w[i]]+1;//数量加一。
                    ans++;
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值