Spring Outing 解题报告

题目描述
You class are planning for a spring outing. N people are voting for a destination out of K candidate places.
The voting progress is below:
First the class vote for the first candidate place. If more than half of the class agreed on the place, the place is selected. The voting ends.
Otherwise they vote for the second candidate place. If more than half of the class agreed on the place, the place is selected. The voting ends.
Otherwise they vote for the third candidate place in the same way and go on.
If no place is selected at last there will be no spring outing and everybody stays at home.
Before the voting, the Chief Entertainment Officer did a survey, found out every one’s preference which can be represented as a permutation of 0, 1, … K. (0 is for staying at home.) For example, when K=3, preference “1, 0, 2, 3” means that the first place is his first choice, staying at home is the second choice, the second place is the third choice and the third place is the last choice.
The Chief Entertainment Officer sends the survey results to the class. So everybody knows the others’ preferences. Everybody wants his more prefered place to be selected. And they are very smart, they always choose the optimal strategy in the voting progress to achieve his goal.
Can you predict which place will be selected?
输入
The first line contains two integers, N and K, the number of people in your class and the number of candidate places.

The next N lines each contain a permutation of 0~K, representing someone’s preference.

For 40% of the data, 1 <= N, K <= 10

For 100% of the data, 1 <= N, K <= 1000

输出
Output the selected place. Or “otaku” without quotes if no place is selected.

样例提示
In the sample case, if the second peoson vote against the first place, no place would be selected finally because the first person must vote against the second place for his own interest. Considering staying at home is a worse choice than the first place, the second person’s optimal strategy is voting for the first place. So the first place will be selected.

样例输入
2 2
1 0 2
2 1 0
样例输出
1
解题思路:这道题的关键是怎么处理每个人的preference,代码如下:

#include <iostream>
#include <vector>
using namespace std;

int main(){
    int N,K;
    vector<vector<int>> priorityMap;
    vector<int> temp(K+1);
    cin>>N>>K;
    for(int i=0;i<N;i++){
        for(int j=K;j>=0;j--){
            int index;
            cin>>index;
            temp[index]=j;
        }
        priorityMap.push_back(temp);
    }
    int candidate=0,vote;
    for(int i=K;i>0;i--){
        vote=0;
        for(int j=0;j<N;j++){
            if(priorityMap[j][i]>priorityMap[j][candidate])
                vote++;
        }
        if(vote>N/2)candidate=i;
    }
    if(candidate!=0)cout<<candidate<<endl;
    else cout<<"otaku"<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值