Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0< N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0 < = Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
Output
Just output one line for one test case, as described in the Description.
Sample Input
2
2
1 5
2 4
2
1 5
6 6
Sample Output
11
12
题意:Sempr在一条直线上从左往右走,在他遇到第奇数块石头时,他会将其往前面扔,扔的距离为:Di,而遇到第偶数个石头时不进行处理。当有
两个石头在同一位置时,则先处理处理能扔的距离远的石头,然后Sempr一直往前走,直到前面已经没有任何石头时,这时候计算Sempr与出发点的距离。
样例:
1 5
2 4
对于样例1的分析:一开始的时候遇到的是第一个石头,他的坐标是1,然后往前扔了5个单位之后,坐标变成6,随后继续往前走,开始遇到第二个石头(坐标是2),忽略,然后继续往前走,又遇到了原来的第一个石头(现在是第三个石头),但是它此时坐标为6,往前扔了5个单位之后,坐标变成11,然后继续往前走,一直走在坐标11时,这时候他遇到的是第四个石头,因此忽略不计。至此,前面已经没有石头了,因此此时离坐标原点的距离为11。
遇见的第几个石头 | 1 | 2 | 3 | 4 |
---|---|---|---|---|
每个石头的坐标 | 1 | 2 | 6 | 11 |
能扔的距离 | 5 | 4 | 5 | 5 |
思路:我们可以运用优先队列解决上述问题,先将每个石头的位置及其能够扔的距离封装成一个结构体。优先队列的优先级即可。利用一个bool变量来控制奇偶,奇数时处理,偶数时不处理。最后的一个石头的坐标即是能扔的最远的距离。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define ll long long
using namespace std;
struct node
{
ll pi;
ll di;
friend bool operator<(node a,node b)
{
if(a.pi==b.pi)
return a.di>b.di;
else
return a.pi>b.pi;
}
};
int main()
{
ll t;
scanf("%lld",&t);
while(t--)
{
ll n;
node a;
priority_queue<node>q;
scanf("%lld",&n);
for(int i=0;i<n;i++)
{
scanf("%lld%lld",&a.pi,&a.di);
q.push(a);
}
bool temp=true;
while(!q.empty())
{
a=q.top();
q.pop();
if(temp)
{
a.pi=a.pi+a.di;
q.push(a);
}
temp=!temp;
}
printf("%lld\n",a.pi);
}
return 0;
}