UVA - 12096 The SetStack Computer

作者:Alex_Dawn

题目描述

Background from Wikipedia: “Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made in mathemat[1]ics concerning the existence of mathematical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a founda[1]tional role to play as specifying a theoretical ideal of mathematical rigor in proofs.”

Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.

The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT, and ADD.

• PUSH will push the empty set {} on the stack.

• DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).

• UNION will pop the stack twice and then push the union of the two sets on the stack.

• INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.

• ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.

For illustration purposes, assume that the topmost element of the stack is A = {{}, {{}}}

and that the next one is B = {{}, {{{}}}}

For these sets, we have |A| = 2 and |B| = 2. Then:

• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.

• INTERSECT would result in the set {{}}. The output is 1.

• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.

Input

An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.

Output

For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with ‘***’ (three asterisks).

Sample Input

2 9 PUSH DUP ADD PUSH ADD DUP ADD DUP UNION 5 PUSH PUSH ADD PUSH INTERSECT

Sample Output

0 0 1 0 1 1 2 2 2 *** 0 0 1 0 0 ***

思路

主要使用了C++ STL中set、stack、map的相关使用,用map将不同的集合映射到ID中,stack表示整个栈,思路参考了算法紫书P116的相关讲解。

注意点

  1. 对于不同类型的集合,对每个集合使用一个ID
  2. 迭代器的正确使用

AC代码

#include "bits/stdc++.h"

/*可改成

#include<iostream>

#include<stack>

#include<set>

#include<map>

#include<vector>

#include<string>

#include<algorithm>

*/

using namespace std;


#define INS(x) inserter(x,x.begin()) //插入迭代器
#define ALL(x) x.begin(),x.end()





typedef set<int> Set;

map<Set,int> IDcache;   //映射到ID

vector<Set> Setcache;   



int ID(Set x){

       if(IDcache.count(x))return IDcache[x];

       Setcache.push_back(x);

       return IDcache[x] = Setcache.size() - 1;

}



int main(){

       int T;

       cin >> T;

       while(T--){

              stack<int> s;

              int n;

              cin >> n;

              for(int i = 0;i < n;i++){

                     string op;

                     cin >> op;

                     if(op[0]=='P')s.push(ID(Set())); // 题目中PUSH等相关操作

                     else if(op[0]=='D')s.push(s.top());

                     else{

                            Set x1=Setcache[s.top()];s.pop();

                            Set x2=Setcache[s.top()];s.pop();

                            Set x;

                            if(op[0]=='U') set_union(ALL(x1),ALL(x2),INS(x));

                            if(op[0]=='I') set_intersection(ALL(x1),ALL(x2),INS(x));

                            if(op[0]=='A'){x=x2;x.insert(ID(x1));}

                            s.push(ID(x));

                     }

                     cout << Setcache[s.top()].size() << endl;

              }

              cout << "***" << endl;

       }

       return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值