[贪心]UVA1037 Magic Coupon

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

题意:一个商店提供优惠券,使用此优惠券能使得商店返回此优惠券的倍数*商品的价格。注意这两个数字都可以是负数。求最大能返回的商品价值。

思路:典型的一道贪心的题目,把优惠券的倍数和商品的价格分别区分为正数和负数,再排序用正数乘正数,负数乘负数可得出结果。

#include<iostream>
#include<algorithm>

using namespace std;

int arry1[100005],arry2[100005],arry3[100005],arry4[100005];

bool cmp1(int x,int y)
{
    return x<y;
}

bool cmp2(int x,int y)
{
    return x>y;
}

int main()
{
    int nc,np;
    int c1=0,c2=0,p1=0,p2=0;
    int i,k;
    cin>>nc;
    for(i=0;i<nc;i++)
    {
        cin>>k;
        if(k>=0) arry1[c1++]=k;
        else arry2[c2++]=k;
    }
    cin>>np;
    for(i=0;i<np;i++)
    {
        cin>>k;
        if(k>=0) arry3[p1++]=k;
        else arry4[p2++]=k;
    }
    sort(arry1,arry1+c1,cmp2);
    sort(arry2,arry2+c2,cmp1);
    sort(arry3,arry3+p1,cmp2);
    sort(arry4,arry4+p2,cmp1);
    int sum=0;
    //cout<<c1<<" "<<c2<<" "<<p1<<" "<<p2<<endl;
    for(i=0;i<c1&&i<p1;i++)
    {
        sum=sum+arry1[i]*arry3[i];
    }
    for(i=0;i<c2&&i<p2;i++)
    {
        sum=sum+arry2[i]*arry4[i];
    }
    cout<<sum<<endl;
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值