Description
Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.
Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.
Input
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Sample Input
2 3 1 1 1 0 1 0
Sample Output
9
Hint
1 2 3 4
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
题意:给出一个n行m列的草地,1表示肥沃,0表示贫瘠,现在要把一些牛放在肥沃的草地上,但是要求所有牛不能相邻,问你有多少种放法。
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<set>
#include <queue>
#include<algorithm>
#include <vector>
const double PI = acos(-1.0);
using namespace std;
int dp[25][20000];
int s[400];
int tot;
int a[15][15];
const int mod = 100000000;
void init() //先预处理出一行所有能行的情况
{
tot = 0;
for(int i = 0; i < (1 << 12); ++ i)
{
if((i & (i << 1)) == 0)
s[tot ++] = i;
}
//printf("%d\n", tot);
}
int main()
{
init();
int n, m, i, j, k;
while(~scanf("%d%d", &n, &m))
{
for(i = 1; i <= n; ++ i)
{
for(j = 1; j <= m; ++ j)
scanf("%d", &a[i][j]);
}
memset(dp, 0, sizeof(dp));
for(i = 0; i < tot; ++ i)
dp[0][i] = 1;
for(i = 1; i <= n; ++ i)
{
for(j = 0; s[j] < (1 << m); ++ j)
{
int res = 1;
for(k = 1; k <= m; ++ k) //判断该状态s[j]是否满足输入的条件
{
if(a[i][k] == 0 && ((1 << (k - 1)) & s[j]))
{
res = 0;
break;
}
}
if(!res)
continue;
if(i == 1)
dp[i][j] += dp[i - 1][j];
else
{
for(k = 0; s[k] < (1 << m); ++ k)
{
if((s[k] & s[j]) == 0)
dp[i][j] = (dp[i][j] + dp[i - 1][k]) % mod; // 累加所有满足与该行条件的上一行
}
}
}
}
int ans = 0;
for(i = 0; s[i] <(1 << m); ++ i)
{
ans = (ans + dp[n][i] ) % mod;
}
printf("%d\n", ans);
}
}