bnuoj 51124 Simple String Problem(状态dp)

Simple String Problem

Time Limit: 2000ms
Memory Limit: 32768KB
This problem will be judged on FZU. Original ID: 2218
64-bit integer IO format: %I64d      Java class name: Main
Type:

Recently, you have found your interest in string theory. Here is an interesting question about strings.

You are given a string S of length n consisting of the first k lowercase letters.

You are required to find two non-empty substrings (note that substrings must be consecutive) of S, such that the two substrings don't share any same letter. Here comes the question, what is the maximum product of the two substring lengths?

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, the first line consists of two integers n and k. (1 <= n <= 2000, 1 <= k <= 16).

The second line is a string of length n, consisting only the first k lowercase letters in the alphabet. For example, when k = 3, it consists of a, b, and c.

Output

For each test case, output the answer of the question.

Sample Input

4
25 5
abcdeabcdeabcdeabcdeabcde
25 5
aaaaabbbbbcccccdddddeeeee
25 5
adcbadcbedbadedcbacbcadbc
3 2
aaa

Sample Output

6
150
21
0

Hint

One possible option for the two chosen substrings for the first sample is "abc" and "de".

The two chosen substrings for the third sample are "ded" and "cbacbca".

In the fourth sample, we can't choose such two non-empty substrings, so the answer is 0.


#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <cmath>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
const double PI = acos(-1.0);
using namespace std;
#define esp  1e-8
const int inf = 99999999;
const int mod = 1000000007;
//freopen("in.txt","r",stdin); //输入重定向,输入数据将从in.txt文件中读取
//freopen("out.txt","w",stdout); //输出重定向,输出数据将保存在out.txt文件中
int dp[70000];
char str[2005];
int vis[30],vv[20];
int main()
{
	int t, n, k, i, j;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d", &n, &k);
		scanf("%s", str);
		int len = strlen(str);
	
		memset(dp, 0, sizeof(dp));
		for (i = 0; i < n; ++i)
		{
			int s = 0;
			for (j = i; j < n; ++j)
			{
				s = s | (1 << (str[j] - 'a'));
				dp[s] = max(dp[s], j - i + 1); //预处理出每种状态的最大值
			}
		}
		int ans = 0;
		for (i = 0; i < (1 << k); ++i)
		{
			for (j = 0; j < k; ++j)
			{
				if (i & (1 << j))
				{
					dp[i] = max(dp[i], dp[i ^ (1 << j)]);//字母多的包含字母少的, 更新最大值
				}
			}
		}
		for (i = 0; i < (1 << k); ++i)
		{
			ans = max(ans, dp[i] * dp[((1 << k) - 1) ^ i]);
		}
		printf("%d\n", ans);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值