hdu 1338 Game Prediction

Game Prediction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1147    Accepted Submission(s): 644


Problem Description
Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
 

Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros.
 

Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.
 

Sample Input
  
  
2 5 1 7 2 10 9 6 11 62 63 54 66 65 61 57 56 50 53 48 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 4
题目没看懂,放了一会儿,然后同学给我说了题意,很简单,结果因为马虎错了两次。
我竟然给排排序。。。。。。。。 。。
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int main(){
   int n,m,s,T=1;
   int a[1005];
   while(scanf("%d%d",&n,&m)&&n&&m){
        memset(a,0,sizeof(a));
        for(int i=1;i<=m;i++){
            scanf("%d",&s);
            a[s]=1;
        }

        //sort(a+1,a+n*m+1);
        int ans=0,count=0;
        for(int i=m*n;i>0;i--){
            if(!a[i]) {
                 ans++;
            }
            else {
                if(ans>0) ans--;
                else count++;

            }
        }
        printf("Case %d: %d\n",T++,count);
   }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值