hdu 1338Game Prediction

Game Prediction
Time Limit: 1000msMemory Limit: 32768KB This problem will be judged on HDU. Original ID: 1338
64-bit integer IO format: %I64d Java class name: Main
Prev Submit Status Statistics Next
Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.
Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.
Sample Input
2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0
Sample Output
Case 1: 2
Case 2: 4
Source
Asia 2002, Beijing (Mainland China)

蛇皮贪心,
题意,这题英文不难看懂,但是中文题目,不好理解。

给你 n个人,给你m张牌,共有n*m张牌从1到n*m;
接下来是,你有的m张牌。

求你最少能应你能赢几场;

记录你输的场数,这是它们出过的大牌,比你现有牌都大,不然你是可以稳赢这局的。总牌数-大牌数-你出过的牌就是对手能出的最大牌;

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue> 
#include<map>
#include<queue>
#include<stack>
typedef long long LL;
using namespace std;
//map<char ,int> mm;
//queue<char> Q;
int main()
{
    int num[111], n, m;
    int f = 0;
    while (cin >> n >> m && (n + m))
    {
        for (int i = 0; i < m; i++)
            scanf("%d", &num[i]);
        sort(num, num + m);
        int fail = 0;
        int k = 0;
        for (int i = m - 1; i >= 0; i--)
        {
            if (m*n - k - fail > num[i]) fail++;
            k++;
        }

        printf("Case %d: %d\n", ++f, m - fail);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值