hdu 5776 sum (鸽巢原理)

Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
已知m1--mn n个数
构造n个序列:
S1=a1;
S2=a1+a2;
。。。。。。
Sn=a1+a2+.....+an;
则有两种可能:
1.若有一个Si是m的倍数,则定理已经得证。
2.上面序列中没有任何一个是m的倍数,则令Rh ≡ Sh % m;
所有余数都小于m且不为0;
则m个余数在[1,m-1]区间内至少有一对Rh==Rk;
吗满足Sk ≡ Sh % m;
设h>k
Sh-Sk=0 % m;
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int main(){
   int a[100100],b[5555];
   int T,n,x;
   scanf("%d",&T);
   while(T--){
       int flag=0;
       scanf("%d%d",&n,&x);
       a[0]=0;
       memset(b,0,sizeof(b));
       for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
        if(a[i]%x==0) flag=1;
       }
       for(int i=1;i<=n;i++){
        (a[i]+=a[i-1])%=x;
        if(b[a[i]]) flag=1;
        else b[a[i]]=1;
        if(a[i]==0) flag=1;
       }
       if(flag) puts("YES"); else puts("NO");
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值