1.交换机的配置
步骤:eth-trunk—创建VLAN—trunk干道—接口划入VLAN—STP—SVI—VRRP—DHCP
1.SW1和SW2起eth-trunk,并划入接口
SW1:
[SW1]interface Eth-Trunk 0
[SW1]interface g0/0/22
[SW1-GigabitEthernet0/0/22]eth-trunk 0
[SW1-GigabitEthernet0/0/22]interface g0/0/23
[SW1-GigabitEthernet0/0/23]eth-trunk 0
SW2:
[SW2]interface Eth-Trunk 0
[SW2]interface g0/0/22
[SW2-GigabitEthernet0/0/22]eth-trunk 0
[SW2-GigabitEthernet0/0/22]interface g0/0/23
[SW2-GigabitEthernet0/0/23]eth-trunk 0
2.创建VLAN
SW1,2,3,4都只用创建VLAN2,因为VLAN1默认存在
[SW1]vlan 2
[SW2]vlan 2
[SW3]vlan 2
[SW4]vlan 2
3.创建trunk干道
SW1,2,3,4配置都是一样的,以SW1为例
SW1:
[SW1]port-group group-member Eth-Trunk 0 GigabitEthernet 0/0/1 to GigabitEthernet 0/0/2
[SW1-port-group]port link-type trunk
[SW1-Eth-Trunk0]port link-type trunk
[SW1-GigabitEthernet0/0/1]port link-type trunk
[SW1-GigabitEthernet0/0/2]port link-type trunk
[SW1-port-group]port trunk allow-pass vlan 2
[SW1-Eth-Trunk0]port trunk allow-pass vlan 2
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 2
[SW1-GigabitEthernet0/0/2]port trunk allow-pass vlan 2
2.STP的配置
SW1:
[SW1]stp mode mstp
[SW1]stp region-configuration
[SW1-mst-region]region-name a
[SW1-mst-region]instance 1 vlan 1
[SW1-mst-region]instance 2 vlan 2
[SW1-mst-region]active region-configuration
[SW1-mst-region]q
[SW1]stp instance 1 root primary
[SW1]stp instance 2 root secondary
SW2:
[SW2]stp mode mstp
[SW2]stp region-configuration
[SW2-mst-region]region-name a
[SW2-mst-region]instance 1 vlan 1
[SW2-mst-region]instance 2 vlan 2
[SW2-mst-region]active region-configuration
[SW2-mst-region]q
[SW2]stp instance 1 root secondary
[SW2]stp instance 2 root primary
SW3:
[SW3]stp mode mstp
[SW3]stp region-configuration
[SW3-mst-region]instance 1 vlan 1
[SW3-mst-region]instance 2 vlan 2
[SW3-mst-region]active region-configuration
SW4:
[SW4]stp mode mstp
[SW4]stp region-configuration
[SW4-mst-region]region-name a
[SW4-mst-region]instance 1 vlan 1
[SW4-mst-region]instance 2 vlan 2
[SW4-mst-region]active region-configuration
3.SVI的配置
SW1:
[SW1]interface vlan 1
[SW1-Vlanif1]ip address 172.16.1.1 25
[SW1-Vlanif1]q
[SW1]interface vlan 2
[SW1-Vlanif2]ip address 172.16.1.129 25
SW2:
[SW2]interface vlan 1
[SW2-Vlanif1]ip address 172.16.1.2 25
[SW2-Vlanif1]q
[SW2]interface vlan 2
[SW2-Vlanif2]ip address 172.16.1.130 25
4.VRRP的配置
SW1:
[SW1]interface vlan 1
[SW1-Vlanif1]vrrp vrid 1 virtual-ip 172.16.1.126
[SW1-Vlanif1]vrrp vrid 1 priority 101
[SW1-Vlanif1]vrrp vrid 1 track interface GigabitEthernet 0/0/24 reduced 2
[SW1-Vlanif1]q
[SW1]int
[SW1]interface vlan 2
[SW1-Vlanif2]vrrp vrid 1 virtual-ip 172.16.1.254
SW2:
[SW2]interface vlan 1
[SW2-Vlanif1]vrrp vrid 1 virtual-ip 172.16.1.126
[SW2-Vlanif1]q
[SW2]interface vlan 2
[SW2-Vlanif2]vrrp vrid 1 virtual-ip 172.16.1.254
[SW2-Vlanif2]vrrp vrid 1 priority 101
[SW2-Vlanif2]vrrp vrid 1 track interface GigabitEthernet 0/0/24 reduced 2
5.DHCP的配置
SW1:
[SW1]dhcp enable
[SW1]ip pool v1
[SW1-ip-pool-v1]network 172.16.1.0 mask 25
[SW1-ip-pool-v1]gateway-list 172.16.1.126
[SW1-ip-pool-v1]dns-list 114.114.114.114
[SW1-ip-pool-v1]q
[SW1]ip pool v2
[SW1-ip-pool-v2]network 172.16.1.128 mask 25
[SW1-ip-pool-v2]gateway-list 172.16.1.254
[SW1-ip-pool-v2]dns-list 114.114.114.114
[SW1]interface vlan 1
[SW1-Vlanif1]dhcp select global
[SW1-Vlanif1]interface vlan 2
[SW1-Vlanif2]dhcp select global
SW2:
[SW2]dhcp enable
[SW2]ip pool v1
[SW2-ip-pool-v1]network 172.16.1.0 mask 25
[SW2-ip-pool-v1]gateway-list 172.16.1.126
[SW2-ip-pool-v1]dns-list 114.114.114.114
[SW2-ip-pool-v1]q
[SW2]ip pool v2
[SW2-ip-pool-v2]network 172.16.1.128 mask 25
[SW2-ip-pool-v2]gateway-list 172.16.1.254
[SW2-ip-pool-v2]dns-list 114.114.114.114
[SW2]interface vlan 1
[SW2-Vlanif1]dhcp select global
[SW2-Vlanif1]interface vlan 2
[SW2-Vlanif2]dhcp select global