2021-08-28

该博客详细解析了一道PAT编程题,涉及look-and-say序列的生成。代码使用C++实现,通过迭代方式根据给定的数字D和次序N计算序列中的第N项。博客指出,此序列的每个数字是前一项中连续数字的描述,例如D1表示有一D,D111表示有一串三个1。博主批评了一些网上代码的不清晰性,并提供了有注释的清晰代码示例。
摘要由CSDN通过智能技术生成

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8

Sample Output:
1123123111

解释都在代码注释了.

网上太多的PAT代码别说注释了 , 连个题意都讲不清楚

show me the codes

#include <bits/stdc++.h>

using namespace std;


// 题目非常拗口, 意思简单其实是:
// 根据以下规则生成序列:
// 第一项S_1是D,其中D为[0-9]任意数字
// 递推规则为:
// S_n+1 为: S_n 中连续数字的描述的拼接,
//    其中描述为 : 数字&数字连续出现次数
int main() {
	int n;
	string s;
	cin >> s >> n;
	for (int k = 1; k < n; k++) {
		string t;
		int top = 1;
		// t 为这次迭代的序列
		// top是某个字符出现的次数,默认1因为至少出现一次
		// 遇见新字符时,输出字符和字符数,并将top重置
		for (int j = 1; j < s.size() + 1; j++) {
			if (s[j] == s[j - 1]) {
				top++;
			}
			else {
				t += s[j - 1] + to_string(top);
				top = 1;
			}
		}
		s = t;
	}
	cout << s;

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值