hdu 1050 Moving Tables

5 篇文章 0 订阅

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20

30

该题是一个贪心的题目。 意思是 把所有桌子搬了 需要的最小时间, 看了样例, 意思就是 重复了几次 

然后最大次数乘以10就哦了。 但是 这样就超时了。。。所以 我们换成另一种思路去想,,可以将门转化成走廊来考虑,

这样 就减少了一半 当然 应该就不会超时了啦~~

#include<stdio.h>
#include<string.h>
int main()
{
	int n,bbs,a,b;
	int s[210];
	scanf("%d",&bbs);
	while(bbs--)
	{
		scanf("%d",&n);
		memset(s,0,sizeof(s));
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			if(a>b)
			{
				int t=a;a=b;b=t;
			} 
			for(int j=(a+1)/2;j<=(b+1)/2;j++)  //直接 把门转化成走廊来考虑 
			{
				s[j]++;
			}
		}
		int maxx=-1;
		for(int i=1;i<200;i++)
		{
			if(s[i]>maxx)
			maxx=s[i];
		}
		printf("%d\n",maxx*10);
		
	}
	
	return 0;


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值