HDU:1969 Pie (二分)

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8476    Accepted Submission(s): 3091


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
   
   
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
   
   
25.1327 3.1416 50.2655
 



Source
 

Recommend
wangye
 

题意:一个人要开派对,邀请他的F个朋友来参加,这个人有N个饼,要切开分给F个朋友和他自己,为了公平起见,切出来的饼的面积得一样,请编写个程序计算出他能切出来的最大的尺寸。


思路:切出来的尺寸肯定介于最小饼和最大饼的尺寸中间,用二分来写。

注意:这里pi不能直接定义它是3.1415926,可能是因为精度原因吧,这里用acos(-1.0)来表示pi。

#include <stdio.h>
#include <math.h>
#define pi acos(-1.0)
double a[10010];
int N,F;
double max(double x,double y)
{
	if(x>y)
	return x;
	else
	return y;
}
double min(double x,double y)
{
	if(x<y)
	return x;
	else
	return y;
}
int judge(double o)//看所有的饼,分成每份的尺寸为o能分成的个数
{
	int cnt=0;
	for(int i=0;i<N;i++)
	{
		cnt=cnt+(int)(a[i]/o);
	}
	return cnt;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&N,&F);
		F++;//吃饼的人包括主人自己 
		double l=0.0,r=0.0;//左右区间 
		for(int i=0;i<N;i++)
		{
			double tmp;
			scanf("%lf",&tmp);
			a[i]=pi*tmp*tmp;
			l=min(l,a[i]);//l表示最小饼的面积 
			r=max(r,a[i]);//r表示最大饼的面积 
		}
		double mid;
		while(r-l>=1e-6)//精度要求 
		{
			mid=(l+r)/2;
			if(judge(mid)>=F)//看所有的饼,分成每份的尺寸为mid能分成的个数 
			{
				l=mid;
			}
			else
			{
				r=mid;
			}
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值