Time Limit: 1000MS |
| Memory Limit: 65536K |
Total Submissions: 14650 |
| Accepted: 4172 |
Description
FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.
The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.
FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.
FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.
Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.
Input
* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line
Output
The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.
Sample Input
6
A
C
D
B
C
B
Sample Output
ABCBCD
题意:又是一群牛,POJ好多牛啊。一个字符串S,现在要变成T。T开始是空串,每次只能从S串的开头或者尾部拿一个字符放入T串中。并且保证T串字典序最小。
题解:要求字典序最小,可以先将S串翻转成逆序串S',不断比较S串与S'串,那个串小将该串的首位字符拿给T串。
注意:此处是比较两个字符串的大小,不是比较他们开头的字符大小。
输出格式略坑,每一行不超过八十个字符。
代码如下:
#include<cstdio>
#include<cstring>
char str[2010];
int main()
{
int n,i,cnt,left,right;
char cow;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;++i)
{
getchar();
scanf("%c",&cow);
str[i]=cow;
}
left=0; right=n-1;
cnt=0;
while(left<=right)
{
bool sign=false;
for(i=0;left+i<=right;++i)
{
if(str[left+i]>str[right-i])
{
sign=true;
break;
}
else if(str[left+i]<str[right-i])
{
sign=false;
break;
}
}
if(sign)
printf("%c",str[right--]);
else
printf("%c",str[left++]);
cnt++;
if(cnt==80)
{
printf("\n");
cnt=0;
}
}
printf("\n");
}
return 0;
}