POJ 2253 Frogger(floyd算法)

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36806 Accepted: 11829

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


题意:青蛙要从A点跳到B点。现在给出n个点的坐标,包括A  B两点在内。任意选择点跳动,求要从A跳到B,青蛙一步至少要跳多远?


题解:这里求的在所有可能的路径中找一个单步最小的路径,而这个单步最小值,就是着条路径中距离最远相邻两点间的距离值。 可以利用floyd算法,经行更新查找,这里像最短路的变形,更像简单的DP问题。


代码如下:


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define maxn 210
#define INF 0x3f3f3f
double map[maxn][maxn];//类似最短路,不过这里map[x][y]中更新从x到y的过程中跳一次最小的距离   
struct node{
	int x,y;
}stone[maxn];
using namespace std;
int main()
{
	int i,j,k,t=1,n;
	while(scanf("%d",&n)&&n)
	{
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=n;++j)
			{
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=INF;
			}
		}
		for(i=1;i<=n;++i)
			scanf("%d%d",&stone[i].x,&stone[i].y);
		double len;
		for(i=1;i<=n;++i)
		{
			for(j=i+1;j<=n;++j)
			{
				len=sqrt((stone[i].x-stone[j].x)*(stone[i].x-stone[j].x)*1.0+(stone[i].y-stone[j].y)*(stone[i].y-stone[j].y)*1.0);
				if(len<map[i][j])
					map[i][j]=map[j][i]=len;
			}
		}
		for(k=1;k<=n;++k)//k作为中介点 
		{
			for(i=1;i<n;++i)
			{
				for(j=i+1;j<=n;++j)
				{
					if(map[i][k]<map[i][j]&&map[k][j]<map[i][j])//如果从i到k和从从k到j的距离都比直接从i到j小,那么从i到j每一步要跳的最小距离就是i到k和k到j中最大的值
					{
						if(map[i][k]<map[k][j])
							map[i][j]=map[j][i]=map[k][j];
						else
							map[i][j]=map[j][i]=map[i][k];
					}
				}
			}
		}
		printf("Scenario #%d\n",t++);
		printf("Frog Distance = %.3f\n\n",map[1][2]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值