Problem S
Time Limit : 10000/5000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 57 Accepted Submission(s) : 18
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.<br>The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).<br>
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.<br>A test case starting with a negative integer terminates input and this test case is not to be processed.<br>
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.<br>
Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
Sample Output
20 10 40 40
对一半的总量进行
0 1 背包的划分
第一个 输出总的减去 dp【sum /2】第二个 sum-dp。。;
ac
#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<fstream>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
int pao[1000000];
int dp[1000000];
int main()
{
int n;
int i,j;
int w,x,sum;
int l;
while(~scanf("%d",&n),n>0)
{ sum=0;
l=0;
memset(dp,0,sizeof(dp));
memset(pao, 0,sizeof(pao));
while(n--)
{
scanf("%d%d",&w,&x); //scanf不超时哦1
while(x--)
{
pao[l++]=w;
sum=sum+w;
}
}
for(i=0;i<l;i++)
{
for(j=sum/2;j>=pao[i];j--)
{
dp[j]=max(dp[j],dp[j-pao[i]]+pao[i]);
}
}
printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
}
return 0;
}