shui

Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
 
Sample Output
100
90
90
95

100
 
#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
struct pao
{
    int n;
    int hour;
    int minute;
    int miao;
    friend bool operator <= (pao a, pao b)
    {
        if(a.hour!=b.hour) return a.hour<b.hour;
        if(a.minute != b.minute) return a.minute < b.minute;
        if(a.miao != b.miao) return a.miao < b.miao ;
        return true;
    }
};
int main()
{
    int t;
    pao a[100];
    int a1;
    int a2;
    int a3;
    int a4;
    int a5;
    int i,j;
    char b;
    while(cin>>t&&t!=-1)
    {
        a1=0;
        a2=0;
        a3=0;
        a4=0;
        a5=0;
        for(i=1;i<=t;i++)
        {
            cin>>a[i].n;
            cin>>a[i].hour;
            cin>>b;
            cin>>a[i].minute;
            cin>>b;
            cin>>a[i].miao;
        }
        for(i=1;i<=t;i++)
        {
            if(a[i].n==5)
            {
                cout<<100<<endl;
            }
            else
            {
                 for(j=1;j<=t;j++)
                 {
                     if(j==i)
                     continue;
                     if(a[i].n==a[j].n)
                    {
                        if(a[j]<=a[i]&&a1==0)
                        {   a1=1;
                            cout<<a[i].n*10+50<<endl;
                        }


                    }
                 }
                 if(a1==0)
                 {
                     cout<<a[i].n*10+55<<endl;
                 }
                 a1=0;
            }


        }


    }
        return 0
;}

Author
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值