1059 Dividing

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19192    Accepted Submission(s): 5380


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 


很典型的一个完全背包问题,背包的容量是总价值的一半。还有如果总价值是奇数,两个人不论怎么分都不会相等,只有是偶数才有可能相等,最后判断条件是容量是总价值的一半的包最大承载的价值是不是总价值的一半


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[7],s;
int dp[60005];

void zeropage(int y)
{
    for(int j=s;j>=y;j--)
        dp[j]=max(dp[j],dp[j-y]+y);
}
void comppage(int x,int y)
{
    for(int j=x;j<=s;j++)
    dp[j]=max(dp[j],dp[j-x]+x);


}



void multpage(int x,int y)
{
    if(x*y>s) { comppage(x,y);return ; }

    int k=1;
    while(k<y)
    {
        zeropage(k*x);
        y=y-k;
        k=k*2;
    }

    zeropage(y*x);

}
int main()
{
       int countn=0;
       while( scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6])!=EOF)
       {

           int flag=0;
           if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0&&a[5]==0&&a[6]==0) exit(0);

        //for(int i=1;i<7;i++)
          //  cout<<a[i]<<" ";
        s=0;
        for(int i=1;i<7;i++)
        s+=a[i]*i;
        if(s%2) flag=1;
       // if(countn) cout<<endl;
        countn++;
        cout<<"Collection #"<<countn<<":"<<endl;
        if(!flag)
        {
        s=s/2;

       // cout<<s<<endl;
        memset(dp,0,sizeof(dp));


        for(int i=1;i<7;i++)
          multpage(i,a[i]);
        //  cout<<dp[s]<<endl;

          if(dp[s]!=s)
            cout<<"Can't be divided."<<endl<<endl;
         else
            cout<<"Can be divided."<<endl<<endl;
        }
        else
         cout<<"Can't be divided."<<endl<<endl;
       }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值