1510 White Rectangles

White Rectangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 897    Accepted Submission(s): 453


Problem Description
You are given a chessboard made up of N squares by N squares with equal size. Some of the squares are colored black, and the others are colored white. Please write a program to calculate the number of rectangles which are completely made up of white squares. 
 

Input
There are multiple test cases. Each test case begins with an integer N (1 <= N <= 100), the board size. The following N lines, each with N characters, have only two valid character values:

# - (sharp) representing a black square;
. - (point) representing a white square.

Process to the end of file.
 

Output
For each test case in the input, your program must output the number of white rectangles, as shown in the sample output.

 

Sample Input
  
  
2 .# .. 4 ..#. ##.# .#.. .#.#
 

Sample Output
  
  
5 15
 
按鹏哥的代码来写的,虽然过了,但是感觉怪怪的
#include <iostream>
#include<cstdio>
using namespace std;
int map[105][105];
int judge(int x,int y1,int y2)
{
    int t=1;

    for(int j=y1;j<=y2;j++)
        if(!map[x][j])
         t=0;

    return t;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        char ch;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
           {
            cin>>ch;
            if(ch=='.')
                map[i][j]=1;
            else
                map[i][j]=0;
           }

           for(int i=0;i<=n+1;i++)
           {
               map[n+1][i]=0;
               map[i][n+1]=0;
           }
          // cout<<map[1][2]<<endl;
           /*for(int i=1;i<=n+1;i++)
            {
                for(int j=1;j<=n+1;j++)
                cout<<map[i][j]<<" ";
                cout<<endl;
            }*/
            int num=0;

            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                {
                    if(map[i][j]==1)
                    {

                        int jj=j;
                        while(map[i][jj])
                        {
                            int ii=i;
                        while(judge(ii,j,jj))
                            {

                                num++;
                                ii++;
                            }
                            jj++;
                        }
                    }

                }

            cout<<num<<endl;

    }
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值