1069 Monkey and Banana

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8843    Accepted Submission(s): 4560


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 
跟矩形嵌套问题很相似,这道题一个长方体长宽高都可以作为高度,任意一面都可以作为底面,所以一组数据有三种情况;然后面积从大到小排序。肯定是大的先取,然后再根据下一个接触面积是不是严格的在上一个的里面,然后就有点那个递增子序列,


#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[100];
struct jx
{
    int l,w,h;
    int r;
};
jx p[100];
int cmp(jx jj,jx xx)
{
    return jj.r>xx.r;
}
int main()
{
    int n;
    int countn=0;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        int k=0;
        int x,y,z;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            p[++k].l=x;p[k].w=y;p[k].h=z;p[k].r=x*y;

            p[++k].l=x;p[k].w=z;p[k].h=y;p[k].r=x*z;

            p[++k].l=z;p[k].w=y;p[k].h=x;p[k].r=z*y;
        }


        sort(p+1,p+n*3+1,cmp);
    //   for(int i=1;i<=n*3;i++)
      //  cout<<p[i].r<<" "<<p[i].h<<endl;

        memset(dp,0,sizeof(dp));
        dp[1]=p[1].h;
        //cout<<dp[1]<<endl;
        int ans=dp[1];
        for(int i=2;i<=n*3;i++)
        {
            int maxn=0;
            for(int j=i-1;j>0;j--)
                if(p[i].r<p[j].r&&((p[i].l<p[j].l&&p[i].w<p[j].w)||(p[i].l<p[j].w&&p[i].w<p[j].l)))
                    if(maxn<dp[j])   //遍历比他大的,然后取最高的那个
                    {
                       maxn=dp[j];
                    }

                dp[i]=maxn+p[i].h; //最高的那个加他自己高度,之前在这一直弄错了
              // cout<<dp[i]<<endl;
                if(ans<dp[i])
                 ans=dp[i];

        }
       printf("Case %d: maximum height = %d\n",++countn,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值