POJ 1703 Find them, Catch them(带权并查集)


Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37383 Accepted: 11528

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)  

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:  

1. D [a] [b]  
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.  

2. A [a] [b]  
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.  

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
题意:t个样例,n个人m个操作,一共两个帮派,A 判断两个人是不是一个帮派,D 两个人不是一个帮派
带权并查集
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAX = 100000+10;
struct person
{
    int num;
    int bang;
    int father;
};
person per[MAX];
int find_father(person &node)
{
    if(node.father == node.num)
        return node.father;
    int temp = node.father;   //这个很重要,因为是通过当前数与父节点关系,父节点与总父节点的关系来判断当前数与总父节点的关系,
    node.father = find_father(per[temp]);
    node.bang = (node.bang + per[temp) % 2; //本来这里写的是(node.bang + per[node.father))%2; 因为经过上一步递归更新父节点,此时的node.father已经是总父节点了,so...
    return node.father;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n,m,a,b,fa,fb;
        char c;
        scanf("%d%d", &n,&m);
        getchar();
        for(int i = 0; i <= n; i++)
        {
            per[i].num = i;
            per[i].father = i;
            per[i].bang = 0;
        }
        while(m--)
        {
            scanf("%c%d%d", &c,&a,&b);
            getchar();

            if(c == 'D')
            {
                fa = find_father(per[a]);
                fb = find_father(per[b]);
                if(fa != fb) {
                    per[fb].father = fa;
                    if(per[a].bang== 0)    //这里要举例找规律
                        per[fb].bang = 1 - per[b].bang;
                    else
                        per[fb].bang = per[b].bang;
                }
            }
            else if(c == 'A')
            {
                fa = find_father(per[a]);
                fb = find_father(per[b]);
                if(fa != fb)
                    printf("Not sure yet.\n");
                else
                {
                    if(per[a].bang == per[b].bang)
                        printf("In the same gang.\n");
                    else
                        printf("In different gangs.\n");
                }
            }

        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值