POJ2503Babelfish(MAP+字典树)


Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 37423 Accepted: 15967

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops
 
题意:输入的每一单词跟每一个单词对应,查找第二个单词对应的第一个单词
直接map<string,string>建立关系,后来输出的时候scanf是不可以的,因为map里面的是string
然后看到有说用字典树写的,然后又写了个字典树,没调试,直接交,水过
//map 2000ms,原因可能是后面用的cout
#include <iostream>
#include <cstring>
#include <string.h>
#include <cstdio>
#include <map>
#include <ctype.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int main()
{
    map<string,string> g;
    char str[30],s1[15],s2[15];
    while(gets(str) && strcmp(str,"") != 0)
    {
        sscanf(str,"%s %s",s1,s2);
        g[s2] = s1;
    }
    while(gets(s2))
    {
        if(g.count(s2) == 0)
            printf("eh\n");
        else
            cout << g[s2]<<endl;
    }
    return 0;
}


字典树 735ms
#include <iostream>
#include <cstring>
#include <string.h>
#include <cstdio>
#include <map>
#include <ctype.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
struct node
{
    int flag;
    node *next[26];
    char s[15];
};
node *root;
void build(char *s2,node *root,char *s1)
{
    node *p,*q;
    p = root;
    int len = strlen(s2);
    for(int i = 0; i < len; i++)
    {
        int id = s2[i] - 'a';
        if(p -> next[id] == NULL)
        {
            q = (node *) malloc(sizeof(node));
            for(int i = 0; i < 26; i++)
                q -> next[i] = NULL;
            q -> flag = 0;
            p -> next [id] = q;
            p = p -> next[id];
        }
        else
            p = p -> next[id];
    }
    p -> flag = 1;
    strcpy(p -> s,s1);
}
void Find(node *root,char *s2)
{
    node *p;
    p = root;
    int len = strlen(s2);
    for(int i = 0; i < len; i++)
    {
        int id = s2[i] - 'a';
        if(p -> next[id] == NULL)
        {
            printf("eh\n");
            return ;
        }
        else
            p = p -> next[id];
    }
    if(p -> flag)
        printf("%s\n",p -> s);
    else
        printf("eh\n");
}
int main()
{
    char str[30],s1[15],s2[15];
    root = (node *)malloc(sizeof(node));
    for(int i = 0; i < 26; i++)
        root->next[i] = NULL;
    while(gets(str) && strcmp(str,"") != 0)
    {
        sscanf(str,"%s %s",s1,s2);
        build(s2,root,s1);
    }
    while(gets(s2))
    {
        Find(root,s2);
    }
    return 0;
}


                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值