fzu 1050 Number lengths

Problem Description

N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * … * 2 * 1)

Input

Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.

Output

For each value of N, print out how many digits are in N!.

Sample Input

1
3
32000
Sample Output

1
1
130271
求n的阶乘的位数
将1000000个结果都先保存在result[1000000]数组中,根据log10(n*(n-1)(n-2)…*2*1)=log10(n)+log10(n-1)+…+log10(2)+log10(1)的公式,

#include <stdio.h>
#include <iostream>
#include <math.h>
#include <algorithm>
using namespace std;
const int maxn=1000005;
double a[maxn]= {0};
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        a[0]=1.0;
        for(int i=1; i<=10; i++)
        {
            a[i]=a[i-1]+log10(i*1.0);
        }
        printf("%d\n",(int)a[n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值